Re: [PATCH] gpib: use assign_bit() where applicable

From: Linus Walleij

Date: Wed Sep 30 2026 - 10:17:28 EST


On Fri, Sep 18, 2026 at 4:19 PM Peng Fan (OSS) <peng.fan@xxxxxxxxxxx> wrote:

> From: Peng Fan <peng.fan@xxxxxxx>
>
> Convert open-coded if/else with set_bit/clear_bit and their
> non-atomic __set_bit/__clear_bit variants to the assign_bit/__assign_bit
> API.
>
> Done with Coccinelle semantic patch and manual fixups.
>
> Signed-off-by: Peng Fan <peng.fan@xxxxxxx>

LGTM
Reviewed-by: Linus Walleij <linusw@xxxxxxxxxx>

Yours,
Linus Walleij