Re: [PATCH v2 18/21] arm64: entry: Split up kernel_ventry macro into separate helper macros

From: Linus Walleij

Date: Wed Sep 30 2026 - 17:28:40 EST


On Fri, Sep 18, 2026 at 6:15 PM Will Deacon <will@xxxxxxxxxx> wrote:

> Handling entry from EL0, EL1h and EL1t in the 'kernel_ventry' assembly
> macro is getting a bit unwieldy as the control flow becomes increasingly
> dependent on the macro arguments.
>
> Split 'kernel_ventry' into three leaf helper macros for EL0, EL1h and
> EL1t, which are then dispatched by simple wrappers.
>
> Signed-off-by: Will Deacon <will@xxxxxxxxxx>

I agree with this change, this is easier to read and understand.
Reviewed-by: Linus Walleij <linusw@xxxxxxxxxx>

Yours,
Linus Walleij