Re: [PATCH 3/3] crypto: sl3516 - Use pm_runtime_resume_and_get()
From: Linus Walleij
Date: Wed Sep 30 2026 - 19:29:50 EST
On Tue, Sep 22, 2026 at 5:20 AM <phucduc.bui@xxxxxxxxx> wrote:
> From: bui duc phuc <phucduc.bui@xxxxxxxxx>
>
> Replace the open-coded pm_runtime_get_sync() + pm_runtime_put_noidle()
> error handling pattern with pm_runtime_resume_and_get(), which already
> does this internally.
>
> No functional change.
>
> Found by manual code inspection.
>
> Signed-off-by: bui duc phuc <phucduc.bui@xxxxxxxxx>
Reviewed-by: Linus Walleij <linusw@xxxxxxxxxx>
Yours,
Linus Walleij