Re: [PATCH v2] ksmbd: use clear_and_wake_up_bit() directly

From: ChenXiaoSong

Date: Thu Oct 01 2026 - 21:57:02 EST


Reviewed-by: ChenXiaoSong <chenxiaosong@xxxxxxxxxx>

On 10/1/26 23:06, Daijiamu wrote:
clear_and_wake_up_bit() was introduced by commit 8236b0ae31c8 ("bdi:
wake up concurrent wb_shutdown() callers.") to replace the open-coded
clear_bit_unlock() + smp_mb__after_atomic() + wake_up_bit() sequence.

Replace the sequence and drop the now-trivial wake_up_oplock_break()
wrapper, calling the helper directly at each call site.

Suggested-by: ChenXiaoSong<chenxiaosong@xxxxxxxxxxxxxxxx>
Signed-off-by: Daijiamu<3058704216@xxxxxx>

--
ChenXiaoSong <chenxiaosong@xxxxxxxxxxxxxxxx>
Chinese Homepage: https://chenxiaosong.com
English Homepage: https://chenxiaosong.com/en