[PATCH v2 0/3] sched/fair: Update decision matrix and rename pinned-task group state

From: Jemmy Wong

Date: Fri Oct 02 2026 - 11:53:43 EST


Patch 1 updates the group-type decision matrix above
sched_balance_find_src_group(), which was never extended for
group_smt_balance (fee1759e4f04) and group_llc_balance (f38cc2f0d8a3).

Patches 2-3 rename the state that records balancing failures caused by
cpus_ptr-pinned tasks. Since commit 6263322c5e8f ("sched/fair: Rewrite
group_imb trigger") it is an affinity flag, not a load-skew measure,
yet it kept the names group_imbalanced and sgc->imbalance, which
suggest a load skew and are easily confused with env->imbalance. They
become group_pinned_imb and sgc->pinned_imb.

Patch 1 does not depend on patches 2-3. No functional change.

Changes in v2:
- Patch 1: llc_balance vs. local has_spare is "force", not "nr_idle"
(Tim Chen); reword the changelog accordingly.
- Patch 2: Rename to group_pinned_imb instead of group_pinned_task
(Tim Chen).
- Patch 3: Rename sgc->pinned_task to sgc->pinned_imb and the reader to
sg_pinned_imb(), to match.

v1: https://lore.kernel.org/all/20260928042018.10618-1-jemmywong512@xxxxxxxxx/

Jemmy Wong (3):
sched/fair: Add smt_balance and llc_balance to the decision matrix
sched/fair: Rename group_imbalanced to group_pinned_imb
sched/fair: Rename sgc->imbalance to sgc->pinned_imb

kernel/sched/fair.c | 66 +++++++++++++++++++++++---------------------
kernel/sched/sched.h | 6 +++-
2 files changed, 39 insertions(+), 33 deletions(-)

--
2.54.0 (Apple Git-157)