Re: [PATCH v12 14/14] coresight: etm3x: rename drvdata->config to sysfs_config
From: Yeoreum Yun
Date: Fri Oct 02 2026 - 13:20:47 EST
On Thu, Sep 24, 2026 at 06:36:06PM +0000, sashiko-bot@xxxxxxxxxx wrote:
> Thank you for your contribution! Sashiko AI review found 1 potential issue(s) to consider:
> - [Low] coresight: missed variable rename in etm_disable_sysfs()
> --
>
> commit 675c6e2b645cb58619c01f29029e27576619cf41
> Author: Yeoreum Yun <yeoreum.yun@xxxxxxx>
>
> coresight: etm3x: rename drvdata->config to sysfs_config
>
> This commit renames the drvdata->config variable to sysfs_config to clarify
> its purpose. It also intends to rename local variables referring to this
> configuration for better readability.
>
> > diff --git a/drivers/hwtracing/coresight/coresight-etm3x-core.c b/drivers/hwtracing/coresight/coresight-etm3x-core.c
> > index 0cad9ecb49b61..67f1b71de8811 100644
> > --- a/drivers/hwtracing/coresight/coresight-etm3x-core.c
> > +++ b/drivers/hwtracing/coresight/coresight-etm3x-core.c
> [ ... ]
> > @@ -627,7 +627,7 @@ static void etm_disable_sysfs(struct coresight_device *csdev)
> > {
> > struct etm_drvdata *drvdata = dev_get_drvdata(csdev->dev.parent);
> > const struct etm_caps *caps = &drvdata->caps;
> > - struct etm_config *config = &drvdata->config;
> > + struct etm_config *config = &drvdata->sysfs_config;
>
> [Severity: Low]
> This isn't a bug, but should this local variable also be renamed to
> sysfs_config?
>
> The commit message mentions "also rename local config variables to
> sysfs_config where they refer to drvdata->sysfs_config", but it appears
> this instance in etm_disable_sysfs() was missed and remains named config.
That's one thing i missed. I'll post in next version.
--
Sincerely,
Yeoreum Yun