> extern inline void sigemptyset(sigset_t *set)
> {
> switch (_NSIG_WORDS) {
> - default:
> - memset(set, 0, sizeof(sigset_t));
> - break;
> case 2: set->sig[1] = 0;
> case 1: set->sig[0] = 0;
> break;
> + default:
> + memset(set, 0, sizeof(sigset_t));
> }
> }
Hellooo? I don't know what language you think you're writing in, but this is
C and the order of case: and default: in switch() is irrelevant. default:
being at the bottom is preferred only for readability, nothing more.
-- No good deed goes unpunished.- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.rutgers.edu Please read the FAQ at http://www.tux.org/lkml/