--- Bartlomiej Zolnierkiewicz <B.Zolnierkiewicz@elka.pw.edu.pl> wrote:
> You've got been mistaken by unfortunate name (Martin changed
> name dmaproc() to udma() in 2.5.12).
> btw. udma() name is really misleading,
> it should be read (u)dma() not udma() :)
Ouch, thanks for the wakeup. I was scanning the code a little too
rapidly it seems...
Martin: why? The old IDE code was admittedly in need of some work, but
a name like dmaproc is very obviously a function. A name like udma is
likely to be (a) misconstrued by lusers like me as a variable, and (b)
misconstrued by all and sundry as something UDMA-specific, rather than
DMA-specific. Would it really be too much grief to rename it back to
dmaproc()? Misleading code will mutate into buggy code.
Now that a few people have cast their eyes over my report+patch, is it
safe to assume that the problem is real and not specific to my systems?
Also, does anyone understand why screwing up a DMA transfer results in
the trashing of inodes? Even better, how come this hasn't bitten many
more people? Surely there are lots of people out there with disks and
CDs on the same IDE cable...
(PS: I have reproduced the problem on two systems so far.)
Do You Yahoo!?
Everything you'll ever need on one web page
from News and Sport to Email and Music Charts
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to firstname.lastname@example.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
This archive was generated by hypermail 2b29 : Tue May 07 2002 - 22:00:25 EST