2.4.19, 2.4.20pre7, problem with aic7xxx driver

From: Stephan von Krawczynski (skraw@ithnet.com)
Date: Fri Sep 20 2002 - 13:19:19 EST

Hello Justin, hello all,

I just came across an interesting phenomenon regarding 2.4.19 / 2.4.20-pre7 and
adaptec scsi. Scene is this:

board: Asus SP97-V with Pentium 200 (non-MMX) (I know it is old)
controllers tried: adaptec 29160, 29160N, 2940 U2W
kernel: 2.4.18-SuSE (distribution 8.0), 2.4.19, 2.4.20-pre7

>From all possible configurations of the above the following work:

kernel 2.4.18-SuSE: with all controllers
kernel 2.4.19 : only with 2940 U2W
kernel 2.4.20-pre7: only with 2040 U2W

All other configurations with newer adaptecs and recent kernels fail during
init of controller. Last message in sight: "PCI: Sharing interrupt xxx"

I tried all interrupts from 5-14 and configurations with other pci devices
plugged in or not. The problem stays the same.
I really wonder what they did to 2.4.18 so that this one works... ??
Any suggestions?


To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

This archive was generated by hypermail 2b29 : Mon Sep 23 2002 - 22:00:31 EST