Re: Kernel Issues

From: Willy Tarreau (
Date: Sun Sep 22 2002 - 05:48:54 EST

On Sun, Sep 22, 2002 at 09:42:21AM +0000, walairat kladmuk wrote:

a few questions :
 - are you sure your CPU isn't overclocked (should be about 1.3 Ghz) ?
 - are you sure your RAM doesn't have defects (try memtest) ?
 - what are the kernel versions shipped with those distros ?
 - perhaps your bios setup has ECC ram enabled or some other bad settings ?

> HD:
> Seagate 40MB

I suppose it's 40 GB instead.

> In my exploring of the installation via the rescue mode, I noticed the
> Config file in boot and was wondering how this is used?

it's used when you want to recompile your kernel. Copy it as
/usr/src/linux/.config, start "make oldconfig" to see if options have changed
between it and the kernel you try to compile, then "make menuconfig" and
disable unwanted options (perhaps machine check exception). Then
"make clean && make dep && make bzImage modules", and try to boot on the new
bzImage (arch/i386/boot/bzImage).

> The third party kernel modules that are asked for when installing might
> also be worth a try... advice here appreciated.

it seems as your kernel hangs very early, too early to even load a module.
> My gut feeling is that given the error message the boot fails when looking
> for an ISApnp card... my motherboard is very new
> ( and doesn't have an
> ISA slot.

try passing "noisapnp" in this case. But you don't need ISA slots to have
onboard ISA chips anyway.
> D Scaife
> (yahoo only sends html style mail which list sees
> as spam hence the reason this comes from elsewhere)

I also have a yahoo account without this problem because I've disabled
HTML mails.
> p.s. Also played with the and tried deleting all those lines
> beginning with isapnp... no luck... these are shots in the dark :)ut is used by insmod, ksymoops and other tools which need to know
the address of certain kernel symbols. That's unrelated to your problem.
Your problem comes from the kernel image itself. At this stage, it cannot
read any file. BTW, have you tried with the kernel used by the install to boot ?

> feeling is that given the error message the boot fails when looking for an
> ISApnp card... my motherboard is very new (see profile) and doesn't have an
> ISA slot.

Your motherboard isn't unique ; these days, it's very hard to find a
motherboard providing at least one ISA slot.
hoping this helps,

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

This archive was generated by hypermail 2b29 : Mon Sep 23 2002 - 22:00:35 EST