Re: [ACPI] [ACPI][2.6.10-rc3][SUSPEND] S3 mode - Cannot resumefrom PCI devices

From: Daniel Gryniewicz
Date: Thu Dec 16 2004 - 13:17:18 EST

On Tue, 2004-12-14 at 19:18 +0100, Pavel Machek wrote:
> Hi!
> > > > This isn't a nice regression.
> > >
> > > So what was the last kernel where it worked?
> >
> > For me, 2.6.9-rc4. I've tried every -rc and -mm since, and it cannot
> > resume. (I get no video on resume, even with 2.6.9-rc4, until X
> Okay, perhaps you are lucky, diff between 2.6.9-rc4 and 2.6.9
> should be fairly small. Could you find which changeset is responsible?
> bkcvs should be really usefull here.
> Pavel

So, I started out by building 2.6.9 to test it failed. It failed.
Then, I started binary searching between 2.6.9-rc4 and 2.6.9, and worked
my way all the way back up to 2.6.9 with it working. I'm now running
the current CVS as of yesterday, with no problems, and with suspend and
resume working. I have no idea what changed between the original build
of 2.6.9 that failed, and the final build that worked, but it would
appear to have been something that was my fault.

Now if I could only get 10-rc4-ck1 to not hang on boot...

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at