Re: [PATCH] cpuset semaphore depth check deadlock fix

From: Paul Jackson
Date: Fri Sep 09 2005 - 18:37:13 EST


Linus wrote:
> We _really_ don't want to have function names like "cs_up()"

I thoroughly agree with your attention to naming, and spent more time
than I will admit in public futzing over this detail.

I wrote the code using cpuset_lock(void) and cpuset_unlock(void), for
reasons such as you state, and out of personnal instinct.

But then I noticed that I wanted these routines to replace up(&sem) and
down(&sem) (in kernel/cpuset.c), so changed them to cpuset_up(&sem) and
cpuset_down(&sem), adding in the explicitly passed argument.

But then I noticed that these names looked "too global" to me, and
intentionally changed that to cs_up(&sem) and cs_down(&sem). I tend
to intentionally choose shorter names for more local stuff, especially
inlines and such that won't even show up on a stack trace.

1) Is cpuset_up(&sem) and cpuset_down(&sem) ok by you? I would like
to have the up/down in there somewhere.

2) How the heck do I make this change:
- Send another patch from scratch, ignoring the first one I sent.
- Send a second patch that layers on the first.
- Let you do the edit.
- ??

--
I won't rest till it's the best ...
Programmer, Linux Scalability
Paul Jackson <pj@xxxxxxx> 1.925.600.0401
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/