Completely dead on resume (no caps lock, nada)

From: Brannon Barrett Klopfer
Date: Fri Aug 04 2006 - 15:54:03 EST


Sorry to bug the entire list with such a vaugue post, but I'm not sure what
driver/subsystem is causing this problem. I'm sure you all are sick of "My
computer won't suspend, what do I do?" posts, but...well, my computer won't

It's a brand-new HP dv8000t laptop (Phoenix BIOS, latest version, core duo,
ahci/ata_piix [native/legacy]). Suspending (echo mem > /sys/power/state)
works fine, but upon resuming, absolutly nothing works -- backlight stays
off, caps/numlock, network, etc. all dead. I've also tried

# cat `which poweroff` > /dev/null # cache it, in case disk dies upon resume
# echo mem > /sys/power/state ; poweroff -f

but it still just hangs (i.e., seems the entire system is just...dead). I've
tried numerous patches from here and there, and tried both native (ahci) and
legacy (ata_piix) sata, and a kernel with as little support as possible --
no usb, ide, smp, module, preempt, etc. I won't flood the lists with other
info, but it's all at

I'd be more than happy to try patches/let someone ssh into my box if it'd
help (new, so nothing sensitive on it yet).

Brannon Klopfer

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at