Re: [patch] change WARN_ON back to "BUG: at ..."

From: Pavel Machek
Date: Sun Dec 24 2006 - 09:19:08 EST


> I've always felt that it is wrong (or at least misleading) that WARN_ON
> prints "BUG". It would have been better if it had said "WARNING", and only
> BUG_ON says "BUG".
> But lots of people have now written downstream log-parsing tools which
> might break due to this change, so I'm inclined to go with Ingo's patch,
> and restore the old (il)logic.

People should not be parsing syslog. If they do, they deserve
occassional breakage.
Thanks for all the (sleeping) penguins.
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at