Re: [PATCH 1/2] x86: rename PTE_MASK to PTE_PFN_MASK

From: Johannes Weiner
Date: Tue Jul 22 2008 - 11:18:54 EST


Jeremy Fitzhardinge <jeremy@xxxxxxxx> writes:

> Johannes Weiner wrote:
>> PTE_PFN_MASK is not symmetric to PAGE_MASK.
> No, it isn't. Is there anything about the name that suggests that it
> should be? PTE_PFN_MASK is for operating on pteval_t-typed values
> extracted from ptes; PAGE_MASK is for operating on addresses.

I meant the naming scheme, not the functionality.

The thing PAGE_MASK and PTE_MASK have in common is that they are masks
and their names indicate what is masked away when applied.

So PAGE_MASK suggests that it masks out page details. And PTE_MASK
suggests that it masks out PTE details.

PTE_PFN_MASK masks suggests that it masks out the flags, according to
the existing naming convention. But it does the opposite.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at