Re: Analyzed/Solved/Bisected: Booting 2.6.30-rc2-git7 very slow

From: Martin Knoblauch
Date: Thu May 28 2009 - 05:00:01 EST

----- Original Message ----

> From: "Miller, Mike (OS Dev)" <Mike.Miller@xxxxxx>
> To: "Owens, James" <JOwens@xxxxxx>; Martin Knoblauch <knobi@xxxxxxxxxxxx>
> Cc: Matthew Wilcox <matthew@xxxxxx>; Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx>; Mike Galbraith <efault@xxxxxx>; "viro@xxxxxxxxxxxxxxxxxx" <viro@xxxxxxxxxxxxxxxxxx>; "rjw@xxxxxxx" <rjw@xxxxxxx>; "linux-kernel@xxxxxxxxxxxxxxx" <linux-kernel@xxxxxxxxxxxxxxx>; "tigran@xxxxxxxxxxxxxxxxxxxx" <tigran@xxxxxxxxxxxxxxxxxxxx>; Kay Sievers <kay.sievers@xxxxxxxx>; "shemminger@xxxxxxxxxx" <shemminger@xxxxxxxxxx>; Jesse Barnes <jbarnes@xxxxxxxxxxxxxxxx>
> Sent: Wednesday, May 27, 2009 8:18:46 PM
> Subject: RE: Analyzed/Solved/Bisected: Booting 2.6.30-rc2-git7 very slow
> > >
> > > Finally, today I built the ccsii driver into the kernel.
> > It was previously modularized and loaded from initrd. The
> > second "sysfs" line went away. But does this make cciss
> > guilty? It is now loaded about 2 seconds earlier in the boot
> > sequence, which is a big change in timing I guess.
> > >
> > > Enlighten me :-)
> >
> > No idea what is going on, but since I saw your May 20
> > message, I have been trying to wake up someone whose day job
> > it should be to care about dl380s and smartarrays. :)
> What? I know Martin has pinged me in the past, but I do not think it was about
> this issue. If there's multiple sysfs entries for cciss I can't explain that
> offhand. We do little to nothing for sysfs in the driver.
> Had something similiar happen recently where "/" changed to "!". Had do to with
> our nested directory structure, /dev/cciss/name vs /dev/name. But we did not
> make that change, either.
Hi Mike, Jim

you are right. I never talked to you about this issue. Actually, I did not suspect CCISS or the DL380 in general to be involved before last week when I retested on the x3650 and the problem went away. Due to day-job and priorities I did not follow up.

> -- mikem
> >
> > If they don't react soon, I'll make this my own day job to
> > try to reproduce it. We will need hardware config details
> > and firmware revs to start.
> >

2x3.4 GHz CPUs
8 GB Memeory
4x72 GB as RAID5 on SA6i controller

BIOS: P51 (07(19/2007)
ILO FW: 1.91
SA6i FW: 2.84

lspci output (-vvv and -xxx) appendend to prevent line wrapping.


Attachment: lspci-bad
Description: Binary data