Re: [PATCH 09/11] ahci: Move generic code into libahci

From: Jeff Garzik
Date: Wed Mar 03 2010 - 13:49:56 EST

On 03/03/2010 12:17 PM, Anton Vorontsov wrote:
This patch should contain no functional changes, just moves code

Excellent! I like how this patch series is split up. You've precisely what you needed to do here -- major code movement should avoid any changes outside the minimum required to build this patch.

Others should follow your example :)

diff --git a/drivers/ata/libahci.c b/drivers/ata/libahci.c
new file mode 100644
index 0000000..3ec32ee
--- /dev/null
+++ b/drivers/ata/libahci.c
@@ -0,0 +1,2059 @@
+ * ahci.c - AHCI SATA low-level routines

this should reflect new filename

diff --git a/drivers/ata/libahci.h b/drivers/ata/libahci.h
new file mode 100644
index 0000000..60bce4e
--- /dev/null
+++ b/drivers/ata/libahci.h
@@ -0,0 +1,330 @@
+ * ahci.c - AHCI SATA low-level routines


Note that my preference for header file name would be ahci.h rather than libahci.h, to reflect that it includes generic AHCI hardware definitions as well as libahci structures and function prototypes.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at