RE: [PATCH] staging: comedi: refactor ni_pcimio driver and usemodule_comedi_pci_driver

From: H Hartley Sweeten
Date: Tue May 15 2012 - 11:41:35 EST

On Tuesday, May 15, 2012 4:29 AM, Ian Abbott wrote:
> On 2012-05-12 00:51, H Hartley Sweeten wrote:
>> +static struct comedi_driver ni_pcimio_driver = {
>> + .driver_name = "ni_pcimio",
> The original used the DRV_NAME macro expanding to "ni_pcimio" here...
>> +static struct pci_driver ni_pcimio_pci_driver = {
>> + .name = "ni_pcimio",
> ... which could also be used here.
> (I realize this is a bit late as the patch is already committed!)

I noticed that. A couple of the comedi drivers do this but it's not consistent.

Personally I don't care for the use of the DRV_NAME (or DRIVER_NAME
or whatever someone wants to call it) usage. It doesn't same any code
space and always makes me have to do a second search to see what the
"name" actually is.

Regardsless, if you prefer this in the drivers please let me know. It
would be nice to have them somewhat consistent before the comedi
support leaves staging.


N‹§²æìr¸›yúèšØb²X¬¶ÇvØ^–)Þ{.nÇ+‰·¥Š{±‘êçzX§¶›¡Ü}©ž²ÆzÚ&j:+v‰¨¾«‘êçzZ+€Ê+zf£¢·hšˆ§~†­†Ûiÿûàz¹®w¥¢¸?™¨è­Ú&¢)ßf”ù^jÇy§m…á@A«a¶Úÿ 0¶ìh®å’i