Re: [PATCH -v2 09/26] infiniband: rename random32() to prandom_u32()

From: Akinobu Mita
Date: Sat Jan 05 2013 - 08:37:08 EST

2013/1/5 Steve Wise <swise@xxxxxxxxxxxxxxxxxxxxx>:
> I'm asking: why are you bothering with renaming the functions? This seems
> like a needless change, _unless_ there are really non-pseudo-random services
> being added.

We already have get_random_byte() which is not pseudo-random number

Apart from that, the naming scheme was confusing without "prandom" prefix.
Because I introduced new functions in the commit 6582c665 ("prandom:
introduce prandom_bytes() and prandom_bytes_state()").
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at