Re: [PATCH 0/2] introduce list_for_each_entry_del

From: David Sterba
Date: Wed Jun 05 2013 - 10:25:55 EST

On Wed, Jun 05, 2013 at 08:53:50AM +0200, Arne Jansen wrote:
> On 05.06.2013 04:09, Jörn Engel wrote:
> > On Tue, 4 June 2013 14:44:35 -0400, Jörn Engel wrote:
> >>
> >> Or while_list_drain?
> I'm fine with while_list_drain, although a name starting with list_
> like all other list macros would be nice. How about just list_drain?

The list_ prefix makes it imho more readable, we know that list_* are
macros, but 'while_list_drain' does not fit to the group. I'd go for

list_drain or list_drain_entry

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at