Re: [BUG] perf top: -z option does not work

From: Namhyung Kim
Date: Tue Aug 12 2014 - 04:09:28 EST

Hi Stephane,

On Tue, 12 Aug 2014 06:44:34 +0200, Stephane Eranian wrote:
> Hi,
> My understanding is that the -z option is used to only print a profile
> since the last refresh. So if I have a refresh of 5s, then it prints the profile
> based on the samples accumulated over the last 5 seconds.

Yep, that's what I understand about the -z behavior too.

> The Z mode used to be available interactively. Nowadays, it seems only
> avail from the cmdline. But it does not work.

Hmm.. it seems the stdio supports 'z' key but TUI don't.

> I run a simple test.
> $ sudo perf top -z
> Then for 5s I run a cycle-burning noploop program.
> It shows up at the top. But when it terminates, the program still stays
> at the top of the profile for a long time. This is not what I'd expect.
> The noploop line should disappear in the next couple of refreshes after
> the program has terminated.
> I am using tip.git and seeing the problem. But it seems, it's been there for a
> long time.
> Any idea what's wrong?

Looking at the code, it only zero out the annotation info but hist
entries. I guess we need to check the flag and throw out existing
entries instead of decaying.

Also I wonder about the order of decaying - shouldn't it be decayed
before processing current entries? It seems current code processes
current entries first and then decays...

I'll prepare patches for this soon.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at