Re: [RFC 00/10] perf pollfd series

From: Jiri Olsa
Date: Mon Aug 25 2014 - 07:05:44 EST

On Fri, Aug 22, 2014 at 05:59:40PM -0300, Arnaldo Carvalho de Melo wrote:
> Hi,
> This is an alternative series to the one Jiri Olsa posted to use the
> fixes he made to the kernel side to allow tooling to notice that a thread had
> exited by looking at the pollfd.revents looking for POLLHUP notifications.
> Once all event file descriptors are removed from the evlist pollfd array,
> tools can make a decision about exiting or telling the user about what happened,
> asking to guidance on what to do next.
> The main difference in this approach is that a new class, which Jiri
> called 'poller' and I called 'fdarray', grew up from what was in evlist->pollfd
> and associated operations, while Jiri first introduced a new class and then
> made tooling use it.
> The details of the implementation should be clear on the changelog
> comments, please let me know if you see any problems, and if I can have your
> acked-by/tested-by/whatever-else tags to get this moving forward.
> Ah, there is still one missing thing which is to make the hists browser
> in live mode be notified that all monitored events are POLLHUP'ed, will get
> to that in followup patches.
> The kernel bits were sent together with my latest pull req to Ingo,
> this series is on top of that branch and is available at:
> git:// perf/pollfd
> - Arnaldo
> Arnaldo Carvalho de Melo (10):
> perf evlist: Introduce perf_evlist__filter_pollfd method
> perf tests: Add test for perf_evlist__filter_pollfd()
> perf evlist: Monitor POLLERR and POLLHUP events too
> perf record: Filter out POLLHUP'ed file descriptors
> perf trace: Filter out POLLHUP'ed file descriptors
> perf evlist: Allow growing pollfd on add method
> perf tests: Add pollfd growing test
> perf kvm stat live: Use perf_evlist__add_pollfd() instead of local equivalent
> perf evlist: Introduce poll method for common code idiom
> tools lib api: Adopt fdarray class from perf's evlist

fdarray name seems too generic for this object, fdpoll looks
more suitable.. also given that the file name is poll.[ch] ;-)

anyway, except for what I've already commented:

Acked-by: Jiri Olsa <jolsa@xxxxxxxxxx>

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at