Re: [PATCH v2 3/9] of: Update Tegra XUSB pad controller binding for USB

From: Stephen Warren
Date: Wed Aug 27 2014 - 12:42:28 EST

On 08/27/2014 10:36 AM, Andrew Bresticker wrote:
On Mon, Aug 25, 2014 at 12:12 PM, Stephen Warren <swarren@xxxxxxxxxxxxx> wrote:
On 08/18/2014 11:08 AM, Andrew Bresticker wrote:
- #phy-cells: Should be 1. The specifier is the index of the PHY to
See <dt-bindings/pinctrl/pinctrl-tegra-xusb.h> for the list of valid
+- mboxes: Must contain an entry for the XUSB PHY mailbox channel.
+ See ../mailbox/mailbox.txt for details.

Can we require the mbox-names property here, so that everything is looked up
by names. I know that the proposed mbox binding states that using indexes is
preferred over names, but that's just silly considering that names are
widely used in most other similar bindings, and are much easier to extend in
a backwards compatible fashion in the face of optional entries. As such, I'd
prefer that all Tegra bindings use foo-names properties where they exist.

Sure, will do.

+Optional properties:
+- vbus-otg-{0,1,2}-supply: VBUS regulator for the corresponding UTMI pad.

Why "-otg"? It's quite possible to have a regulator for VBUS even on systems
that don't support OTG, but rather simply have the ability to turn VBUS off.

Because they're the VBUS supplies for the OTG 'lanes'. It doesn't
really add anything, so I'll omit the "-otg".

Ah right. In that case, if the lanes are named "OTG" lanes in the HW docs, I'm happy either way. If you did decide to keep the "-otg", rewording as "VBUS regulator for the corresponding OTG UTMI pad" would make the meaning clearer.
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at