Re: thunderbolt: Deletion of unnecessary checks before the function call "ring_free"

From: Andreas Noever
Date: Sun Nov 23 2014 - 10:45:45 EST

On Sun, Nov 23, 2014 at 4:20 PM, Joe Perches <joe@xxxxxxxxxxx> wrote:
> On Sun, 2014-11-23 at 15:14 +0100, SF Markus Elfring wrote:
>> >> 2. Are any additional prefixes appropriate so that further name space
>> >> conflicts can be better avoided?
>> >
>> > To avoid possible external naming conflicts, add tb_ prefix to
>> > various ring_<foo> structs and functions.
>> Do you imagine that any XEN software developers need also to reconsider
>> this implementation detail?
> I think static functions can be named whatever
> the developer chooses.
Do symbols which are not exported (no EXPORT_SYMBOL_(GPL)) cause
conflicts? I was under the impression that those are module private.
If they are indeed private then I would prefer to not rename them.
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at