Re: [patch] CodingStyle: add some more error handling guidelines

From: SF Markus Elfring
Date: Wed Dec 03 2014 - 07:31:59 EST

> diff --git a/Documentation/CodingStyle b/Documentation/CodingStyle
> index 9f28b14..9c8a234 100644
> --- a/Documentation/CodingStyle
> +++ b/Documentation/CodingStyle
> @@ -392,7 +392,12 @@ The goto statement comes in handy when a function exits from multiple
> locations and some common work such as cleanup has to be done. If there is no
> cleanup needed then just return directly.
> -The rationale is:
> +Choose label names which say what the goto does or why the goto exists. An
> +[...] Avoid
> +using GW-BASIC names like "err1:" and "err2:". Also don't name them after the
> +goto location like "err_kmalloc_failed:"

I find this documentation approach not safe and clear enough so far.

* How should the reference to an other programming language help in the understanding
of the recommended naming convention for jump labels?

* To which source code place should the word "location" refer to?
- jump source
- jump target

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at