Re: [PATCH 2/4] mm: rename __mlock_vma_pages_range() to populate_vma_page_range()

From: David Rientjes
Date: Wed Feb 11 2015 - 14:59:44 EST

On Wed, 11 Feb 2015, Kirill A. Shutemov wrote:

> __mlock_vma_pages_range() doesn't necessary mlock pages. It depends on
> vma flags. The same codepath is used for MAP_POPULATE.


> Let's rename __mlock_vma_pages_range() to populate_vma_page_range().
> This patch also drops mlock_vma_pages_range() references from
> documentation. It has gone in commit cea10a19b797.
> Signed-off-by: Kirill A. Shutemov <kirill.shutemov@xxxxxxxxxxxxxxx>

I think it makes sense to drop the references about "downgrading"
mm->mmap_sem in the documentation since populate_vma_page_range() can be
called with it held either for read or write depending on the context.

Acked-by: David Rientjes <rientjes@xxxxxxxxxx>
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at