Re: [PATCH 2/4] mm: rename __mlock_vma_pages_range() to populate_vma_page_range()

From: Kirill A. Shutemov
Date: Thu Feb 12 2015 - 06:03:42 EST

On Wed, Feb 11, 2015 at 11:59:33AM -0800, David Rientjes wrote:
> On Wed, 11 Feb 2015, Kirill A. Shutemov wrote:
> > __mlock_vma_pages_range() doesn't necessary mlock pages. It depends on
> > vma flags. The same codepath is used for MAP_POPULATE.
> >
> s/necessary/necessarily/
> > Let's rename __mlock_vma_pages_range() to populate_vma_page_range().
> >
> > This patch also drops mlock_vma_pages_range() references from
> > documentation. It has gone in commit cea10a19b797.
> >
> > Signed-off-by: Kirill A. Shutemov <kirill.shutemov@xxxxxxxxxxxxxxx>
> I think it makes sense to drop the references about "downgrading"
> mm->mmap_sem in the documentation since populate_vma_page_range() can be
> called with it held either for read or write depending on the context.

I'm not sure what references you're talking about.

Is it about this part:

* If @nonblocking is non-NULL, it must held for read only and may be
* released. If it's released, *@nonblocking will be set to 0.


The comment is still true as far as I can say. It comes from up_read() in

Kirill A. Shutemov
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at