Re: [PATCH v12 2/7] x86/arch_prctl/64: Rename do_arch_prctl to do_arch_prctl_64

From: Kyle Huey
Date: Fri Nov 18 2016 - 11:39:25 EST

On Thu, Nov 17, 2016 at 11:27 PM, Ingo Molnar <mingo@xxxxxxxxxx> wrote:
> * Kyle Huey <me@xxxxxxxxxxxx> wrote:
>> In order to introduce new arch_prctls that are not 64 bit only, rename the
>> existing 64 bit implementation to do_arch_prctl_64(). Also rename the second
>> argument to arch_prctl(), which will no longer always be an address.
>> #ifdef CONFIG_X86_64
>> void entry_SYSCALL_64(void);
>> +long do_arch_prctl_64(struct task_struct *task, int code, unsigned long arg2);
>> #endif
> Could you please also rename the weirdly named 'code' argument to 'option',
> to be in line with the existing sys_prctl() interface nomenclature?

arch_prctl consistently uses 'code' throughout the kernel and in the
main page. This renaming should probably be done separately if

- Kyle