Re: [PATCH] KVM: nVMX: Rename prepare_vmcs02_*_full to prepare_vmcs02_*_extra
From: Paolo Bonzini
Date: Thu Jun 06 2019 - 16:23:22 EST
On 06/06/19 21:19, Krish Sadhukhan wrote:
> The big chunk of the work in this function is done via
> prepare_vmcs02_constant_state(). It seems cleaner to get rid of
> prepare_vmcs02_early_full(), call prepare_vmcs02_constant_state()
> directly from prepare_vmcs02_early() and move the three vmcs_write16()
> calls to prepare_vmcs02_early().
This is just a mechanical search and replace, you can send a patch on
top to inline it in the caller.