Re: [PATCH] kernel-doc: rename the kernel-doc directive 'functions' to 'specific'

From: Jonathan Corbet
Date: Tue Oct 15 2019 - 14:27:30 EST

On Sun, 13 Oct 2019 13:53:59 +0800
Changbin Du <changbin.du@xxxxxxxxx> wrote:

> The 'functions' directive is not only for functions, but also works for
> structs/unions. So the name is misleading. This patch renames it to
> 'specific', so now we have export/internal/specific directives to limit
> the functions/types to be included in documentation. Meanwhile we improved
> the warning message.

I agree with the others that "specific" doesn't really make things
better. "Interfaces" maybe; otherwise we could go for something like
"filter" or "select".

Paint mine green :)

Whatever we end up with, I think it should be added as a synonym for
"functions". Then the various selectors that are actually pulling out
docs for functions could be changed at leisure - or not at all. I'd
rather not see a big patch changing everything at once.