Re: [PATCH] kernel-doc: rename the kernel-doc directive 'functions' to 'specific'
From: Matthew Wilcox
Date: Tue Oct 15 2019 - 20:48:30 EST
On Wed, Oct 16, 2019 at 08:03:24AM +0800, Changbin Du wrote:
> On Tue, Oct 15, 2019 at 04:54:39AM -0700, Matthew Wilcox wrote:
> > On Tue, Oct 15, 2019 at 11:25:53AM +0200, Thomas Zimmermann wrote:
> > > > My preference would be to use 'symbols'. I tried to come up with something
> > > > but 'symbols' is better than anything I came up with.
> > >
> > > Maybe 'interfaces' or 'artifacts'. The term 'symbols' is just as
> > > imprecise as 'functions'.
> > I suggested 'identifier' because that's the term used in the C spec (6.2.1):
> > : An identifier can denote an object; a function; a tag or a member
> > : of a structure, union, or enumeration; a typedef name; a label name;
> > : a macro name; or a macro parameter.
> I also prefer this one now. I was looking for something like this. My original
> idea is 'prototype', but that is only for function.
We could also go with 'declaration' or 'definition'. But I prefer