Re: [PATCH] fs/hfs: remove unused macro to tame gcc

From: Viacheslav Dubeyko
Date: Fri Nov 06 2020 - 12:56:39 EST




> On Nov 5, 2020, at 7:47 PM, Alex Shi <alex.shi@xxxxxxxxxxxxxxxxx> wrote:
>
> Couple macro are duplicated defined and they are not used. So
> to tame gcc, let's remove them.
>
> fs/hfsplus/part_tbl.c:26:0: warning: macro "HFS_DRVR_DESC_MAGIC" is not
> used [-Wunused-macros]
> fs/hfsplus/part_tbl.c:30:0: warning: macro "HFS_MFS_SUPER_MAGIC" is not
> used [-Wunused-macros]
> fs/hfsplus/part_tbl.c:21:0: warning: macro "HFS_DD_BLK" is not used
> [-Wunused-macros]
> net/l2tp/l2tp_core.c:73:0: warning: macro "L2TP_HDRFLAG_P" is not used
> [-Wunused-macros]
>


Sorry, but this patch doesn’t make sense at all, from my point of view.
It is the declaration of magics that could take place on the volume.
Even if these declarations haven’t been used in the code, then
it is important to be aware about this. I don’t think that it make sense
to follow to the compiler’s complains in this case. I believe that
it needs to keep these declarations.

Thanks,
Viacheslav Dubeyko.


> Signed-off-by: Alex Shi <alex.shi@xxxxxxxxxxxxxxxxx>
> Cc: linux-fsdevel@xxxxxxxxxxxxxxx
> Cc: linux-kernel@xxxxxxxxxxxxxxx
> ---
> fs/hfs/hfs.h | 2 --
> fs/hfsplus/part_tbl.c | 2 --
> 2 files changed, 4 deletions(-)
>
> diff --git a/fs/hfs/hfs.h b/fs/hfs/hfs.h
> index 6f194d0768b6..12a807d9dbc0 100644
> --- a/fs/hfs/hfs.h
> +++ b/fs/hfs/hfs.h
> @@ -15,11 +15,9 @@
> #define HFS_MDB_BLK 2 /* Block (w/i partition) of MDB */
>
> /* magic numbers for various disk blocks */
> -#define HFS_DRVR_DESC_MAGIC 0x4552 /* "ER": driver descriptor map */
> #define HFS_OLD_PMAP_MAGIC 0x5453 /* "TS": old-type partition map */
> #define HFS_NEW_PMAP_MAGIC 0x504D /* "PM": new-type partition map */
> #define HFS_SUPER_MAGIC 0x4244 /* "BD": HFS MDB (super block) */
> -#define HFS_MFS_SUPER_MAGIC 0xD2D7 /* MFS MDB (super block) */
>
> /* various FIXED size parameters */
> #define HFS_SECTOR_SIZE 512 /* size of an HFS sector */
> diff --git a/fs/hfsplus/part_tbl.c b/fs/hfsplus/part_tbl.c
> index 63164ebc52fa..ecda671d56a8 100644
> --- a/fs/hfsplus/part_tbl.c
> +++ b/fs/hfsplus/part_tbl.c
> @@ -23,11 +23,9 @@
> #define HFS_MDB_BLK 2 /* Block (w/i partition) of MDB */
>
> /* magic numbers for various disk blocks */
> -#define HFS_DRVR_DESC_MAGIC 0x4552 /* "ER": driver descriptor map */
> #define HFS_OLD_PMAP_MAGIC 0x5453 /* "TS": old-type partition map */
> #define HFS_NEW_PMAP_MAGIC 0x504D /* "PM": new-type partition map */
> #define HFS_SUPER_MAGIC 0x4244 /* "BD": HFS MDB (super block) */
> -#define HFS_MFS_SUPER_MAGIC 0xD2D7 /* MFS MDB (super block) */
>
> /*
> * The new style Mac partition map
> --
> 1.8.3.1
>