Re: [GIT PULL] Memory folios for v5.15

From: Jeff Layton
Date: Wed Aug 25 2021 - 08:08:58 EST

On Tue, 2021-08-24 at 22:32 +0100, David Howells wrote:
> Theodore Ts'o <tytso@xxxxxxx> wrote:
> > What do you think of "struct pageset"? Not quite as short as folios,
> > but it's clearer.
> Fine by me (I suggested page_set), and as Vlastimil points out, the current
> usage of the name could be renamed.

I honestly fail to see how any of this is better than "folio".

It's just a name, and "folio" has the advantage of being fairly unique.
The greppability that Willy mentioned is a perk, but folio also doesn't
sound similar to other words when discussing them verbally. That's
another advantage.

If I say "pageset" in a conversation, do I mean "struct pageset" or "a
random set of pages"? If I say "folio", it's much more clear to what
I'm referring.

We've had a lot of time to get used to "page" as a term of art. We'd get
used to folio too.
Jeff Layton <jlayton@xxxxxxxxxx>