Repost - uugetty dies with 1.2.10/11

John Michael Floyd (
Wed, 28 Jun 1995 15:55:38 +1000 (EST)

I am having some problems with uugetty with V1.2.10 and V1.2.11 of the kernel.
The version of uugetty is 2.0.7e.

On a connecting call by modem the program gets a segment violation.
This occurs after connection but before the login prompt.
The same binary of the uugetty runs happily on V1.2.8.

I have tried a number of compile options - optimizations, -g, different
compilers etc. No luck. Ie for the uugetty binary!

My main compile is using Elf libraries 5.0.9 and 5.1.2 but I have also tried the
4.7.2 aout libs.

I have tried to debug this as much as possible - but I have run into problems
doing this. However, it appears to be memory overwrite, with some variables
locations being zeroed (pointers). This is what causes the seg. but i
cannot find the region that actually does it.

So my main thought is that there is some bug in this version of the kernel.

Anyone else seeing these problems? I have had no other problems with 1.2.10.

John Floyd