Disappearing SB16 MIDI problem in 2.0.4

Mark Orr (markorr@intersurf.com)
Mon, 08 Jul 1996 23:04:49 -0500

...no, it's not the semicolon typo. :-)

No, I noticed something odd about the behavior of the sound code
in 2.0.4. I compile most things as modules, and once I set up
2.0.4 and tried out the SB16 daughterboard midi, it worked.

BUT, then it didn't work. I noticed that after kerneld
UNLOADED the driver, and then another program had it reload it,
it wouldn't find the midi device.

I even tried manually loading it with insmod and modprobe --
Nathan Laredo's playmidi, and resetmidi returned:
/dev/midi00: no such device or address.

It worked the first time, but never again after it was unloaded.

The syslog reports:
Jul 8 21:54:43 darkstar kernel: Sound: Nonexistent MIDI interface 0
Jul 8 21:55:02 darkstar kernel: sb: Interrupt test on IRQ5 failed -

Kernel 2.0.4 ; modules 2.0.0 -- SB16scsi2 w/WaveBlaster.
settings: 220hex, 5 irq, 1 dma, 5 hi-dma, 330 MPU, -1 midi-IRQ
(..as per the menuconfig ; in previous version 2.0.1-2.0.3, it
didn't work at all, trying -1,0,1, and 3)

Yes, I too am quite puzzled as to all the changes since 2.0.0
(usslite 3.4.2) which worked perfectly for me.

Mark Orr