Re: Floppy problem.

Illuminati Primus (
Sat, 8 Feb 1997 19:00:44 -0500 (EST)

That was me writing about how Linux couldn't access my PS/1's disk drive..
Eventually, I gave up and tried another method. What I did is I copied
color.gz to lodlin16's directory, compiled a kernel w/ initrd support on
another machine, downloaded the kernel, and then booted with lodlin. I
was able to the install from the CDROM and eventually get linux working on
my PS/1.. My life on the slowest computer in existance suddenly became
slightly more tolerable :) (And I've never had to use the disk drive in
linux again).

I wonder if anyone knows why Linux wasnt able to communicate with my
PS/1's disk drive correctly? If theres some way to kludge it to work (or
maybe even fix it correctly?)?
Anyhow, now my 386 is doing a much better job holding down some papers
across the room. Maybe I'll give it to my sisters >:).

On Sat, 8 Feb 1997, Chris Evans wrote:

> Hi,
> As a favour for a friend I am installing Linux on her ancient 386SX...
> just to run console based things like (primarily) telnet. However, said
> machine is a PS/1.
> Problem 1) (SOLVED) -- stupid IBM bios doesn't report proper disk
> geometry. lilo parameters fix this.
> Problem 2) The moment it comes to load in the compressed image on the
> floppy, I get "I/O error on dev 02:00 sector 0" (or something similar).
> A search showed up a similar post by someone else a while back but it was
> not answered satisfactorily...
> So, is there any way to get a floppy drive working under Linux on a PS/1
> computer? Perhaps some floppy=really_quite_crap parameter I can give lilo?
> Cheers,
> Chris.