Re: unable to mount root (kernel panic) (SOLUTION)

tk (
Thu, 26 Jun 1997 11:43:36 -0800

Thanks to everyone for their advice.
I got the problem solved a couple of days ago (took me a while to finish this).
I never got a specific answer to solve my problem, and I doubt anyone will
ever have the same problem again, but just for the record I figured I'd
post how I got it fixed.

I run Slackware 96, with three partitions on /dev/hda. hda1 is dos, hda2 is
swap and hda3 is linux.

I used a boot floppy to start the machine. Once I got the first prompt, I
typed 'mount root=/dev/hda3' first. This launched the Linux kernel on hda3.

I recompiled the kernel and modules.
I then run liloconfig and made hda1 the lilo boot partition.
I then rebooted from the floppy, using a kernel image on a rescue floppy.
I run fdisk against hda (fdisk /dev/hda) and made hda1 the bootable partition.
Rebooting now the linux kernel on hda3 came up by itself, without
assistance from the floppy.
Problem solved.

Apparently there was something wrong in the kernel image which caused the
error message
"Kernel panic: VFS: unable to mount root fs on 03:03"
to appear when I tried booting from the hard disk.

I had tried fdisk before, making sure hda1 is bootable, and then
reinstalling lilo. Didn't work.

I also tried making hda3 bootable with fdisk and installing lilo on it.
Didn't work. This by the way, never works for me. I thought it's possible,
but apparently not.

Therefore I know there was some problem which occurred when I compiled the
kernel which caused the error.

Anyway, thanks for all the ideas that everybody sent.


Troy Korjuslommi ALLIANCE STUDIO
Technical Director
e. ph. (310) 458-0884 fx. (310) 395-5741
--------- SAMPLE SITES ---------