Data corruption with NFS in 2.1.x?

Heinz Ulrich Stille (
Fri, 16 Jan 1998 20:11:31 +0100 (MET)


I use two computers: an i486-100 as server, and a pentium-100 as diskless
workstation. They are connected via 100MBit ethernet cards based on the
DEC 21140. On the server runs kernel 2.0.3{0-3}; on the workstation I
tried 2.1.{64-76} and 2.1.80-pre{1,2} (that is, any of 2.1.x that did
work at all for me).

I tried to compile gcc- with 'make bootstrap'; after that, 'make
compare' complained about differing results of the two compile runs. The
differences are not always in the same files or places.

With 2.0.x as client, no differences occur.
I tried this with NE2000 compatible cards with the same results.
A friend has the same problem with different hardware (intel-based).

What's wrong?

MfG, Ulrich

there's no sense in being stupid about things and giving the vote to
people who were poor or criminal or insane or female, who'd only use
it irresponsibly.                         T. Pratchett, "Lords and Ladies"