Re: VM: Found a writable swap-cached page!

Anders Melchiorsen (
28 Jul 1998 22:57:52 +0200

Magnus Sjoegren <> writes:

> > Works just fine for me, using zgv on a 16MB 486-DX100. Are you using
> > the new kernel framebuffer, or is this using the traditional console
> > stuff?

> I managed to force these VM messages without X+netscape running
> only squake and updatedb just now.
> I also tried to reproduce it with dosemu as Anders Melchiorsen
> suggested but without any luck.

I think I can reproduce it at will now. Dosemu will indeed cause this
to happen here.

I can start a bunch of XEmacs processes, no problem. Swap is being
used and no message. Once I start xdos (Dosemu in X) the message

Or I can start xdos and then the XEmacs bunch and when xdos starts to
get swapped out the message will appear.

Or I can just start a lot of xdos processes and the message will

My conclusion is that Dosemu swapped out gives this message.

And the message appears A LOT. I have a couple of thousand
VM:... messages in my log now, after having tested and provoked it for
half an hour.

Kernel 2.1.111 with various patches (I cannot remember them all!).
32MB Pentium/133 and using the traditional console (but this was all
done in X).

I just tried with dosemu on a console and filled memory with
XEmacs (in X). This did NOT show the message.

Well, that was the results of my tests so far. Anything else I can do
to help track this down?

Regards, Anders
(address is valid)

Stitzer's Vacation Principle: take half as much clothing and twice as much money.

- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to Please read the FAQ at