Re: autofs/smbfs - delayed mounting?

Nicholas J. Leon (
Tue, 1 Dec 1998 20:51:21 -0500 (EST)

On Tue, 1 Dec 1998, Michael H. Warfield wrote:

# Something fishy here... Process 758 has gone zombie... I'm really
# curious what the parent processes to 769 and 758 were... I'm also curious
# to see what your automount map looked like.

Ok, I'll warn 'ya, my setup is bizarre :)

floppy -fstype=auto :/dev/fd0
boot -fstype=ext2 :/dev/hda1
zip -fstype=auto :/dev/sda4
cd -fstype=auto :/dev/hdd
cdr -fstype=auto :/dev/sr0
madi -rw,soft,intr,rsize=8192,wsize=8192 madi:/
pico -rw,soft,intr,rsize=8192,wsize=8192 pico:/
tao -fstype=smb tao:/c
nicadaemus -fstype=smb nicadaemus:/c

# I see that there is no password (it would have appeared as an XXXXX
# in the ps display). Is there a password on the share? If you run the
# smbmount program (the binary - not any front end scripts such as mine)
# manually, do you get prompted for a password?

No passwords are used. And no, if I run stuff manually, I don't get
prompted for a password.

# Since you are using autofs, are you using my shell script
# <> or another script for

Another, a very simple one:



NEW="\\\\`echo $CPATH | cut -f1 -d:`"
SHARE=`echo $CPATH | cut -f2 -d/`


#echo smbmount $NEWSHARE -c "mount $POINT -u 0 -g 0"
smbmount $NEWSHARE -c "mount $POINT -u 0 -g 0" &
sleep 10
killall -HUP smbmount


I put the 'sleep && killall' because it ``fixed'' my problem (sending any signal to smbmount makes it exit and continue normally).

This is hackish, very much so. But I was just testing for right now.

# I also see that the -N option (no password) is NOT present. That # makes me even more suspicious that smbmount is attempting to prompt for # a password and you are hung there waiting...

I don't think so. If I run

/sbin/mount.smb tao:/c /mnt1

it works just fine. But anyhook, I just changed my script to use -N on smbmount and it didn't make any difference.


-- n i c h o l a s j l e o n / elegance through simplicity / / good fortune through truth / / not all questions have answers /

- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to Please read the FAQ at