Re: [PATCH] gpiolib: add a common prefix to GPIO descriptor flags

From: Bartosz Golaszewski

Date: Fri Sep 12 2025 - 03:27:03 EST


From: Bartosz Golaszewski <bartosz.golaszewski@xxxxxxxxxx>


On Tue, 09 Sep 2025 14:28:43 +0200, Bartosz Golaszewski wrote:
> While these flags are private within drivers/gpio/, when looking at the
> code, it's not really clear they are GPIO-specific. Since these are GPIO
> descriptor flags, prepend their names with a common "GPIOD" prefix.
>
> While at it: update the flags' docs: make spelling consistent, correct
> outdated information, etc.
>
> [...]

Applied, thanks!

[1/1] gpiolib: add a common prefix to GPIO descriptor flags
https://git.kernel.org/brgl/linux/c/571c65bb2f4d17198189cf8d161b96f32674642b

Best regards,
--
Bartosz Golaszewski <bartosz.golaszewski@xxxxxxxxxx>