Re: [PATCH] gpiolib: add a common prefix to GPIO descriptor flags

From: Linus Walleij

Date: Wed Sep 10 2025 - 17:53:45 EST


On Tue, Sep 9, 2025 at 2:28 PM Bartosz Golaszewski <brgl@xxxxxxxx> wrote:

> From: Bartosz Golaszewski <bartosz.golaszewski@xxxxxxxxxx>
>
> While these flags are private within drivers/gpio/, when looking at the
> code, it's not really clear they are GPIO-specific. Since these are GPIO
> descriptor flags, prepend their names with a common "GPIOD" prefix.
>
> While at it: update the flags' docs: make spelling consistent, correct
> outdated information, etc.
>
> Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@xxxxxxxxxx>

That's a good patch.
Reviewed-by: Linus Walleij <linus.walleij@xxxxxxxxxx>

Yours,
Linus Walleij