Re: [PATCH 01/32] thermal/intel: Stop using 32-bit MSR interfaces
From: Jürgen Groß
Date: Thu Jul 02 2026 - 07:27:36 EST
On 02.07.26 11:31, Ingo Molnar wrote:
* Juergen Gross <jgross@xxxxxxxx> wrote:
- rdmsr(MSR_IA32_THERM_INTERRUPT, l, h);
+ rdmsrq(MSR_IA32_THERM_INTERRUPT, val.q);
if (cpu_has(c, X86_FEATURE_PLN) && !int_pln_enable)
- wrmsr(MSR_IA32_THERM_INTERRUPT,
- (l | (THERM_INT_LOW_ENABLE
- | THERM_INT_HIGH_ENABLE)) & ~THERM_INT_PLN_ENABLE, h);
+ val.l = (val.l | THERM_INT_LOW_ENABLE | THERM_INT_HIGH_ENABLE) &
+ ~THERM_INT_PLN_ENABLE;
This could be written as something like:
val.l |= THERM_INT_LOW_ENABLE | THERM_INT_HIGH_ENABLE;
val.l &= ~THERM_INT_PLN_ENABLE;
Which would be far more readable than the multi-line statement.
+ val.l = (val.l | PACKAGE_THERM_INT_LOW_ENABLE |
+ PACKAGE_THERM_INT_HIGH_ENABLE) &
+ ~PACKAGE_THERM_INT_PLN_ENABLE;
Okay, will change.
Juergen
Attachment:
OpenPGP_0xB0DE9DD628BF132F.asc
Description: OpenPGP public key
Attachment:
OpenPGP_signature.asc
Description: OpenPGP digital signature