Re: [PATCH 01/32] thermal/intel: Stop using 32-bit MSR interfaces
From: Ingo Molnar
Date: Thu Jul 02 2026 - 05:37:17 EST
* Juergen Gross <jgross@xxxxxxxx> wrote:
> - rdmsr(MSR_IA32_THERM_INTERRUPT, l, h);
> + rdmsrq(MSR_IA32_THERM_INTERRUPT, val.q);
> if (cpu_has(c, X86_FEATURE_PLN) && !int_pln_enable)
> - wrmsr(MSR_IA32_THERM_INTERRUPT,
> - (l | (THERM_INT_LOW_ENABLE
> - | THERM_INT_HIGH_ENABLE)) & ~THERM_INT_PLN_ENABLE, h);
> + val.l = (val.l | THERM_INT_LOW_ENABLE | THERM_INT_HIGH_ENABLE) &
> + ~THERM_INT_PLN_ENABLE;
This could be written as something like:
val.l |= THERM_INT_LOW_ENABLE | THERM_INT_HIGH_ENABLE;
val.l &= ~THERM_INT_PLN_ENABLE;
Which would be far more readable than the multi-line statement.
> + val.l = (val.l | PACKAGE_THERM_INT_LOW_ENABLE |
> + PACKAGE_THERM_INT_HIGH_ENABLE) &
> + ~PACKAGE_THERM_INT_PLN_ENABLE;
Ditto.
Thanks,
Ingo