Re: [PATCH v2 2/4] arm64: dts: qcom: shikra-cqm-evk: Enable display and add ili7807s panel

From: Krzysztof Kozlowski

Date: Mon Jul 06 2026 - 03:24:23 EST


On 06/07/2026 08:04, Nabige Aala wrote:
> + lcd_bias: regulator-lcd-bias {
> + compatible = "regulator-fixed";
> + regulator-name = "lcd_bias";
> + vin-supply = <&vph_pwr>;
> + gpio = <&tlmm 151 GPIO_ACTIVE_HIGH>;
> + enable-active-high;
> + pinctrl-0 = <&lcd_bias_en>;
> + pinctrl-names = "default";
> + };
> +
> + vph_pwr: vph-pwr-regulator {

Why so inconsistent names?

Anyway, drop the node, not used and not controllable.

> + compatible = "regulator-fixed";
> + regulator-name = "vph_pwr";
> + regulator-always-on;
> + regulator-boot-on;



Best regards,
Krzysztof