Re: [PATCH v2 2/4] arm64: dts: qcom: shikra-cqm-evk: Enable display and add ili7807s panel
From: Arpit Saini
Date: Mon Jul 06 2026 - 05:21:58 EST
Hi Krzyszto,
On 7/6/2026 12:03 PM, Krzysztof Kozlowski wrote:
On 06/07/2026 08:04, Nabige Aala wrote:
+ lcd_bias: regulator-lcd-bias {Why so inconsistent names?
+ compatible = "regulator-fixed";
+ regulator-name = "lcd_bias";
+ vin-supply = <&vph_pwr>;
+ gpio = <&tlmm 151 GPIO_ACTIVE_HIGH>;
+ enable-active-high;
+ pinctrl-0 = <&lcd_bias_en>;
+ pinctrl-names = "default";
+ };
+
+ vph_pwr: vph-pwr-regulator {
Anyway, drop the node, not used and not controllable.
As per the schematics of LCD display Bias driver , vph_pwr is used as vin for that.
So I created vph_pwr , if you want , I can drop that in next patchset.
Thanks,
Arpit
+ compatible = "regulator-fixed";
+ regulator-name = "vph_pwr";
+ regulator-always-on;
+ regulator-boot-on;
Best regards,
Krzysztof