Re: [PATCH] usb: rust: Use pin_init::zeroed for usb_device_id initialization

From: Greg Kroah-Hartman

Date: Wed Jul 08 2026 - 08:12:12 EST


On Sun, Jun 28, 2026 at 12:08:56PM +0200, Miguel Ojeda wrote:
> On Fri, Jun 26, 2026 at 12:50 AM Nicolás Antinori
> <nico.antinori.7@xxxxxxxxx> wrote:
> >
> > All types in `bindings` implement `Zeroable` if they can. This enables
> > using `pin_init::zeroed()` for `usb_device_id` initialization instead
> > of relying on `..unsafe { MaybeUninit::zeroed().assume_init() }`.
> >
> > This change improves readability and removes unnecessary unsafe blocks.
> >
> > Link: https://github.com/Rust-for-Linux/linux/issues/1189
> > Suggested-by: Benno Lossin <lossin@xxxxxxxxxx>
> > Signed-off-by: Nicolás Antinori <nico.antinori.7@xxxxxxxxx>
>
> Looks fine -- if needed I can pick it up via `rust-next`.

I'll take it, thanks.

greg k-h