Re: [PATCH v3] staging: rtl8723bs: rename bLinkInfoDump to snake_case
From: Greg KH
Date: Wed Jul 08 2026 - 10:30:19 EST
On Wed, Jul 08, 2026 at 05:10:24PM +0300, Alon Shamay wrote:
> Rename bLinkInfoDump to link_info_dump to follow the kernel coding
> style, which discourages CamelCase and Hungarian notation. Issue
> reported by checkpatch.pl.
>
> Signed-off-by: Alon Shamay <pastraman1@xxxxxxxxx>
> ---
> v3: use real name in From/Signed-off-by
> v2: drop unintended whitespace/reformatting introduced by editor; rename only
>
> drivers/staging/rtl8723bs/core/rtw_mlme_ext.c | 2 +-
> drivers/staging/rtl8723bs/include/drv_types.h | 2 +-
> drivers/staging/rtl8723bs/os_dep/os_intfs.c | 4 ++--
> 3 files changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/staging/rtl8723bs/core/rtw_mlme_ext.c b/drivers/staging/rtl8723bs/core/rtw_mlme_ext.c
> index a86d6f97cf02..607771a0af21 100644
> --- a/drivers/staging/rtl8723bs/core/rtw_mlme_ext.c
> +++ b/drivers/staging/rtl8723bs/core/rtw_mlme_ext.c
> @@ -4780,7 +4780,7 @@ void _linked_info_dump(struct adapter *padapter)
> int UndecoratedSmoothedPWDB;
> struct dvobj_priv *pdvobj = adapter_to_dvobj(padapter);
>
> - if (padapter->bLinkInfoDump) {
> + if (padapter->link_info_dump) {
> if ((pmlmeinfo->state&0x03) == WIFI_FW_STATION_STATE)
> rtw_hal_get_def_var(padapter,
> HAL_DEF_UNDERCORATEDSMOOTHEDPWDB,
> diff --git a/drivers/staging/rtl8723bs/include/drv_types.h b/drivers/staging/rtl8723bs/include/drv_types.h
> index 552d0c5fa47f..7b61be9dfea0 100644
> --- a/drivers/staging/rtl8723bs/include/drv_types.h
> +++ b/drivers/staging/rtl8723bs/include/drv_types.h
> @@ -344,7 +344,7 @@ struct adapter {
>
> u8 bFWReady;
> u8 bBTFWReady;
> - u8 bLinkInfoDump;
> + u8 link_info_dump;
as you are only ever setting this to 0, why is it needed at all? It
will never change value so the logic can be removed, right? If not, ok,
but then it should be a 'bool', right?
thanks,
greg k-h