Re: [PATCH 6/6] vDSO: Rename HAVE_GENERIC_VDSO to VDSO_DATASTORE
From: Vincenzo Frascino
Date: Thu Jul 09 2026 - 05:43:56 EST
On 09/07/2026 08:28, Thomas Weißschuh wrote:
> Over time the meaning of HAVE_GENERIC_VDSO has become off.
> Today it only controls the availability of the vDSO datastore.
>
> Rename the symbol to match its function.
>
> Signed-off-by: Thomas Weißschuh <thomas.weissschuh@xxxxxxxxxxxxx>
Reviewed-by: Vincenzo Frascino <vincenzo.frascino@xxxxxxx>
> ---
> arch/loongarch/Kconfig | 2 +-
> arch/powerpc/Kconfig | 2 +-
> arch/riscv/Kconfig | 2 +-
> include/linux/vdso_datastore.h | 6 +++---
> lib/vdso/Kconfig | 6 +++---
> lib/vdso/Makefile | 2 +-
> 6 files changed, 10 insertions(+), 10 deletions(-)
>
> diff --git a/arch/loongarch/Kconfig b/arch/loongarch/Kconfig
> index d8d252325017..41ed648fcec9 100644
> --- a/arch/loongarch/Kconfig
> +++ b/arch/loongarch/Kconfig
> @@ -153,7 +153,6 @@ config LOONGARCH
> select HAVE_FUNCTION_GRAPH_TRACER
> select HAVE_FUNCTION_TRACER
> select HAVE_GCC_PLUGINS
> - select HAVE_GENERIC_VDSO
> select HAVE_HW_BREAKPOINT if PERF_EVENTS
> select HAVE_IOREMAP_PROT
> select HAVE_IRQ_EXIT_ON_IRQ_STACK
> @@ -213,6 +212,7 @@ config LOONGARCH
> select TRACE_IRQFLAGS_SUPPORT
> select USE_PERCPU_NUMA_NODE_ID
> select USER_STACKTRACE_SUPPORT
> + select VDSO_DATASTORE
> select VDSO_GETRANDOM
> select ZONE_DMA32 if 64BIT
>
> diff --git a/arch/powerpc/Kconfig b/arch/powerpc/Kconfig
> index f7ce5fff81f0..c6bc2cd6cc83 100644
> --- a/arch/powerpc/Kconfig
> +++ b/arch/powerpc/Kconfig
> @@ -256,7 +256,6 @@ config PPC
> select HAVE_FUNCTION_GRAPH_TRACER
> select HAVE_FUNCTION_TRACER if !COMPILE_TEST && (PPC64 || (PPC32 && CC_IS_GCC))
> select HAVE_GCC_PLUGINS
> - select HAVE_GENERIC_VDSO
> select HAVE_HARDLOCKUP_DETECTOR_ARCH if PPC_BOOK3S_64 && SMP
> select HAVE_HARDLOCKUP_DETECTOR_PERF if PERF_EVENTS && HAVE_PERF_EVENTS_NMI
> select HAVE_HW_BREAKPOINT if PERF_EVENTS && (PPC_BOOK3S || PPC_8xx)
> @@ -328,6 +327,7 @@ config PPC
> select SYSCTL_EXCEPTION_TRACE
> select THREAD_INFO_IN_TASK
> select TRACE_IRQFLAGS_SUPPORT
> + select VDSO_DATASTORE
> select VDSO_GETRANDOM
> #
> # Please keep this list sorted alphabetically.
> diff --git a/arch/riscv/Kconfig b/arch/riscv/Kconfig
> index 9aa8c4df0cd8..019fb4799943 100644
> --- a/arch/riscv/Kconfig
> +++ b/arch/riscv/Kconfig
> @@ -171,7 +171,6 @@ config RISCV
> select HAVE_FUNCTION_ARG_ACCESS_API
> select HAVE_FUNCTION_ERROR_INJECTION
> select HAVE_GCC_PLUGINS
> - select HAVE_GENERIC_VDSO if MMU
> select HAVE_IRQ_TIME_ACCOUNTING
> select HAVE_KERNEL_BZIP2 if !EFI_ZBOOT
> select HAVE_KERNEL_GZIP if !EFI_ZBOOT
> @@ -227,6 +226,7 @@ config RISCV
> select THREAD_INFO_IN_TASK
> select TRACE_IRQFLAGS_SUPPORT
> select UACCESS_MEMCPY if !MMU
> + select VDSO_DATASTORE if MMU
> select VDSO_GETRANDOM if MMU && 64BIT
> select USER_STACKTRACE_SUPPORT
> select ZONE_DMA32 if 64BIT
> diff --git a/include/linux/vdso_datastore.h b/include/linux/vdso_datastore.h
> index 3dfba9502d78..13b01baf3497 100644
> --- a/include/linux/vdso_datastore.h
> +++ b/include/linux/vdso_datastore.h
> @@ -7,10 +7,10 @@
> extern const struct vm_special_mapping vdso_vvar_mapping;
> struct vm_area_struct *vdso_install_vvar_mapping(struct mm_struct *mm, unsigned long addr);
>
> -#ifdef CONFIG_HAVE_GENERIC_VDSO
> +#ifdef CONFIG_VDSO_DATASTORE
> void __init vdso_setup_data_pages(void);
> -#else /* !CONFIG_HAVE_GENERIC_VDSO */
> +#else /* !CONFIG_VDSO_DATASTORE */
> static inline void vdso_setup_data_pages(void) { }
> -#endif /* CONFIG_HAVE_GENERIC_VDSO */
> +#endif /* CONFIG_VDSO_DATASTORE */
>
> #endif /* _LINUX_VDSO_DATASTORE_H */
> diff --git a/lib/vdso/Kconfig b/lib/vdso/Kconfig
> index eedb04974fd5..597f5f0f9681 100644
> --- a/lib/vdso/Kconfig
> +++ b/lib/vdso/Kconfig
> @@ -1,11 +1,11 @@
> # SPDX-License-Identifier: GPL-2.0
>
> -config HAVE_GENERIC_VDSO
> +config VDSO_DATASTORE
> bool
>
> config GENERIC_GETTIMEOFDAY
> bool
> - select HAVE_GENERIC_VDSO
> + select VDSO_DATASTORE
> help
> This is a generic implementation of gettimeofday vdso.
> Each architecture that enables this feature has to
> @@ -20,6 +20,6 @@ config GENERIC_VDSO_OVERFLOW_PROTECT
>
> config VDSO_GETRANDOM
> bool
> - select HAVE_GENERIC_VDSO
> + select VDSO_DATASTORE
> help
> Selected by architectures that support vDSO getrandom().
> diff --git a/lib/vdso/Makefile b/lib/vdso/Makefile
> index 405f743253d7..ac304def42d6 100644
> --- a/lib/vdso/Makefile
> +++ b/lib/vdso/Makefile
> @@ -1,3 +1,3 @@
> # SPDX-License-Identifier: GPL-2.0-only
>
> -obj-$(CONFIG_HAVE_GENERIC_VDSO) += datastore.o
> +obj-$(CONFIG_VDSO_DATASTORE) += datastore.o
>
--
Regards,
Vincenzo