Re: [PATCH v2 1/3] powerpc/numa: Simplify find_primary_domain_index

From: IBM

Date: Fri Jul 10 2026 - 00:04:57 EST


Srikar Dronamraju <srikar@xxxxxxxxxxxxx> writes:

> Initialize the return value once and use a single exit path in
> find_primary_domain_index().
>
> This is a small cleanup that keeps the existing behavior unchanged while
> making the control flow easier to follow.
>
> Signed-off-by: Srikar Dronamraju <srikar@xxxxxxxxxxxxx>


Cleanup LGTM. Feel free to add:
Reviewed-by: Ritesh Harjani (IBM) <ritesh.list@xxxxxxxxx>